10-02-2007, 10:43 PM

I hope you guys can help me out with a litle problem that i'm having.

I've been playing FF VIII since the release years ago on the PSX, unfortuanly i sold my PSX quite a while ago.
But ofcourse i started to miss playing FF VIII and i was lucky enough to get my hands on the PC version.

So i installed it and started up the game, intro movie went just fine untill the game itself started..
All over the screen you will see black holes and its really anoying to play. It only apears on the background and never on the world map or during fights.


Ofcourse the first thing i thought about was a driver problem but thats kinda rare with a game as old as this one, so i thought maybe my graphics card just doesnt agree with the game.
So i tryd it on another computer ( with a NVIDIA FX5200 )
But the same problem apeared.
After i tryd installing it on my laptop because perhaps my 22" screen had a too high resolution but that didint work either, i basicly tryd every setting in the FF8 Config but nothing helped.

I browsed these forums for a bit but couldnt really find a Thread with a similair subject.

So hopefully someone can help me with this


10-03-2007, 01:57 AM
What operating system are you using?

10-03-2007, 02:04 AM
well, I'd agree that it's probably a driver problem. If you can, set the game to use software rendering. Also try forcing the resolution to something lower i.e. 640x480.

Finally, apply all the patches for the game.

And if it still glitches out, grab the PSX version and use a PSX emulator. I am doing just that (my PSOne died).

10-03-2007, 11:42 AM
If you are using WinXP and nVIDIA graphics card, you'll need ff8sqeanvpatch. I had the same problem, but patchig the game helped.

10-03-2007, 12:33 PM
I'd like to thank every1 for replying to my post, after i installed the patch UltimaN referred me to, it worked just like he said.

Thanks again

11-06-2007, 03:31 AM
Well, I just got the game last weekend. EA Classics title, which means it's 50% off what it used to cost when it was first released but still ass pricey. In any case, here's my misadventure with the PC edition. System runs Windows XP Professional x64 edition.

Firstly, installation itself was already a problem. Clicking install from the autorun results in an empty error dialog box. Fix:
1. Right click on installer
2. Select Properties
3. Select "Compatibility" tab
4. Check the box next to "Run this program in compatibility mode for:"
5. Select Windows 98/Windows ME from the list.
6. Click Apply
7. Click OK.
8. Run installer again.

Now apply all the patches. We'd want the game to be fully patched before proceeding

Second issue does not apply to everyone, but people who're practicing something called "safe computing" will notice that the game will bomb out before the opening movie if they try to start a new game while in limited user mode. To fix:

1. Open command prompt (Start, Run, type cmd.exe into the box and click OK)
2. change over to the program files directory/drive (usually C:\Program Files (x86)).
3. type 'cacls "Square Soft, Inc." /T /E /G Everyone:C'. Replace Square Soft, Inc with whatever folder you installed the game to. Press enter.
4. Close the command prompt
5. Open the registry editor (Start, run, type regedit into the box, click OK).
6. Navigate over to HKEY_LOCAL_MACHINE/SOFTWARE/WoW6432Node
7. Right click on Square Soft Inc., select "Permissions..."
8. Click on "Users" on the top pane and check the box under Allow and next to Full Control. Click OK.
9. Close Registry editor

This should fix up most problems people will encounter. However, for people with NVidia GeForce 6 series or newer cards, there will be one more problem. The patch will not fix the black boxes because the problem is in hardware, not software. GeForce 6 series cards and newer do not support palletized textures, which the game heavily relies on. GeForce5 cards do support the feature- it was only disabled via drivers, so the patch allows the game to bypass the drivers and re-activate the feature directly on the card. This cannot be done on GeForce 6 or newer cards.

Oh, did I mention that Soundfonts are also not supported on the system?

However, there are a couple of options:
1. Use software renderer mode. The graphics will not look as nice and it might slow down the game considerably due to the processing load placed on the CPU, but it's a price to pay for using newer hardware. Plus, at the power of modern CPUs, the chunk may not be that large.
2. Get the PSX edition and emulate it. With the right plugins the graphics quality can surpass even that of the PC edition. And the sound would probably be better anyway because the PSX has a better sound system than the PC, unless you could get soundfonts working. The only downside? You either go get a PSOne ROM illegally or tear out your hair trying to dump your own.