01-09-2010, 08:14 PM
Okay, so you know how after the Highbridge event with Mika where he sends himself, the temples are accessible again and you get some fayth dialogue when you revisit each of them by solving the Cloister again, along with a few spheres for treasures?

So here I was revisiting Macalania, I went through the cloister with the ice pillars and stuff, made the path to the exit, went ahead up the stairs... and found myself back in the main great hall of the temple right back where I started, right next to the guard at the top of the stairs!

I figured I must have done something wrong, went through the cloister 2-3 more times (never wanna do it again), see if I can find another exit, same thing happened, so I did a Google search and looked through Gamefaqs and found nothing notable about revisiting Macalania cloister or the exit taking you back to the starting point.

So then I just randomly decided to try going in and back out, didn't work. Finally, as a last resort attempt I tried solving the cloister, making the path, so I hear that chime sound, but instead of taking it, going out the way I came in after solving it... and it worked! Finally found myself in the little place where you fight Seymour, leading to a path to the bottom of the temple leading to the fayth chamber.

But... just wondering, is this problem universal, or is my game just glitched? Only because there was not a word about it on Google or Gamefaqs... you'd think if it was real I'd come across something saying precisely that you have to solve the cloister and then go back out the way you came, or at least someone else on some board having the same problem... but no mention of it at all!

01-09-2010, 09:25 PM
It might force you to redo the puzzle in the temple, which you did and then got out right? I can't be sure because I've never gone back into Macalania Temple after the initial trip. Assuming you for the Destruction Sphere/Treasure you're done with it?

01-09-2010, 09:59 PM
I got the Destruction Sphere on my initial trip. I'm talking about the thing in the temples you can't do until after you have the airship and Yuna's name is cleared as a traitor. Revisiting the chambers of the fayth where they give you a bit of dialogue, as well as some spheres.

In all the temples you're required to re-do the cloister so you can reach the chamber of the fayth. In Macalania, apparently, when you do this, you have to solve the cloister, but instead of exiting forward across the bridge that you made, you have to go backwards the way you came in. Going forward takes you back out to the entrance, not to the chamber of the fayth.

Also simply going in and out backwards won't work. Must go in, make the bridge, then go out the way you came in instead of crossing it.

But I'm asking if this is like that with anyone else's game, or just me. You'd think something would be said about it somewhere online if it's a given that you have to do that.

01-09-2010, 10:03 PM
I've never heard of going back to the Chambers to get spheres before, what kind of spheres do you get?

And I have no answers as to if it's glitched or not, almost makes me want to fire up an old save file.

01-09-2010, 10:25 PM
Like the dark blue ones used to make something out of empty nodes. Luck Sphere, Accuracy Sphere, Evasion Sphere, Magic Def Sphere, etc.

01-10-2010, 12:14 AM
I actually never tried this myself because I initially thought that Macalania temple would be different considering that I never actually visited a fayth there and because I had to do the Cloister of Trials to leave not to enter. I don't know about anything you said, just sounds really confusing or a really weird glitch. I guess I can go ahead and beat Dark Shiva and enter but I'm too lazy these days...

01-10-2010, 03:10 AM
I am slightly confused with what you are trying to get across here. But from what I can tell it seems you might have done things in a different order than I did therefore getting a different "reaction" out of the temple.

09-28-2014, 12:56 AM
I am slightly confused with what you are trying to get across here. But from what I can tell it seems you might have done things in a different order than I did therefore getting a different "reaction" out of the temple.

I found out that u dont even have to do the trials simply enter watch the ice break then exit from whence u came and it puts u at the entrace tot he chamber of fayth glad i can finally be of assistance on one of these forums instead of just reading some answer :)

11-02-2014, 03:26 AM
You do have to redo the Cloister of Trials to visit the Chamber of the Fayth in Macalania, after the initial visit. It's not a glitch as I see it, it's just they confuse us with the direction you're supposed to go.