05-18-2010, 08:01 PM
I've recently purchased a copy of FFVII for the PSone, and it works okay, but with one minor, itsy, tiny drawback - it doesn't save. It doesn't recognize the memory card (both on my PSone and PS2). The memory cards themselves are new and work great with other games. The FFVII discs are also in a very good condition.

Has anyone experienced something like this before?

05-18-2010, 08:06 PM
I experienced the opposite, where the memory card was apparantly faulty and wouldn't save any game yet the games themselves would try to only for the save to be corrupted.

There's obviously something wrong with the game, if it was the memory cards then you would have this problem with other games.

Chocolate Misu
05-18-2010, 09:10 PM
I never experienced any saving problems with my copy. The only thing wrong with mine is that it stalls itself out sometimes during battles, but it works itself out if I leave it on all day/night.

05-18-2010, 11:18 PM
What exactly happens when you try to save the game? Does it recognize the card and load it up, but then throws up an error when you try and save? Or does the card not show up at all (is it greyed out on the screen to select the memory card to save?)

It may be that your memory card is corrupt and needs reformating (although if that is the case it should ask you to do that automatically when attempting to save). Third-party memory cards in particular are notorious for corrupting, but even official Sony ones can be problematic (I lost my ultimate FFVIII save file to a corrupted Sony memory card many years ago for instance.)

As for it not working with a PS2 card, this is normal, because PS1 games do not work with PS2 cards (you can move save files onto them off a PS1 memory card though for storage, but you cannot load them in a PS1 game), as PS1 games do not recognize PS2 memory cards.

If your PS1 memory card is indeed faulty, all you can really do is try and track down a replacement through game stores, although that might be difficult given PS1 peripherals are quite hard to find now.

05-18-2010, 11:29 PM
I remember buying some 3rd party snazzy clear memory cards that did not work with Roller Coaster tycoon.... I did not test all of my games, only about of 10-12.

05-19-2010, 11:32 AM
Miraculously, I sat down and tried saving the game again, using Slot 2, and it SAVED!
I mean, I tried the second slot before, but it didn't obey much. Slot 1 probably kinda old or something, from all those years of loving\abusing relationship *hearts*

Thanks everyone, for your help and support!

05-19-2010, 01:05 PM
Ah yes, I've had trouble getting PS1 memory cards to work with slot 1 on my first generation PS2 on a number of occasions. So I guess it must be a hardware issue.

Anyway, it's good to know you sorted it out. :)